Life In 19x19
http://www.lifein19x19.com/

Font issue on Panda-EGG
http://www.lifein19x19.com/viewtopic.php?f=33&t=17041
Page 1 of 1

Author:  Jujube [ Fri Nov 08, 2019 3:21 pm ]
Post subject:  Font issue on Panda-EGG

Hi

I'm trying out the Japanese version of Panda-EGG.

I've downloaded the Japanese language pack on Windows and set it as the active language so my Windows UI is in Japanese.

The Panda-EGG interface is in Japanese apart from the fonts on the GUI (buttons, etc), which are garbled. Probably an encoding issue?

Any tips?

Attachment:
キャプチャ.PNG
キャプチャ.PNG [ 76.25 KiB | Viewed 4841 times ]

Author:  Jujube [ Fri Nov 08, 2019 3:43 pm ]
Post subject:  Re: Font issue on Panda-EGG

Ok I figured it out. I'll keep the post here in the event anyone wants to run the application with the correct fonts.

Windows runs in a locale and doesn't cache the correct fonts when it loads applications if the locale is set to English (this is different from installing and using language packs).

I downloaded the free Locale Emulator here https://github.com/xupefei/Locale-Emulator/releases and it's as simple as navigating to the Panda-EGG file at C:\PANDA\EGG\Egg.exe and then you right-click the executable, then select Locale Emulator > Run In Japanese.

Attachment:
Capture.PNG
Capture.PNG [ 45.58 KiB | Viewed 4839 times ]

Author:  Drew [ Fri Dec 06, 2019 5:23 am ]
Post subject:  Re: Font issue on Panda-EGG

That's a neat tool. Thank you for sharing.

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/